Start a new topic

Game stuck on “Updating” after comet crash...

Hey, I’ve tried to open the app multiple times after a comet failed to open. Now I’m unable to log in without the game getting stuck on the “updating game content” screen. Other peoples games seem to be working fine - just seems to be my account... My coins can be seen in the corner when I open the app (ignore the connecting to game server). Hopefully I haven’t wasted $15 and lost my account!

4 people have this problem

I also have this exact same problem. Crashed when opening a 12 hour comet. Force closed the app and now it’s stuck on “updating game content”. Tried logging in with other iOS devices, but no luck. Seems to be tied to my Game Center.

I had the same issue, the update fixed it for a while but it did it again last night.


Still wait for a response to my ticket.


1 person likes this
I have the same issue and support just says they will tell the dev. Terrible support. May have to put up a bad review after all.

1 person likes this
same here. they should be able to restore it to normal status quickly

Same here. I am also stuck on update screen. The support is horrible. Have a 10 day pending ticket from them regarding another issue. Asked me for my Player ID to check it and 8 days later still no answer. Totally worthless.


I understand there's a fix coming to unblock all users


Any idea when this fix might be coming? I've had it happen to two separate accounts now. Seems like once I've reached player level 7 it locks up. 

Interesting. Im also level 7. Leveled up a couple of hours before this happened.

Game is super fun, but I’m not allowed to play lol

So you got screwed twice. 
I also did. After hitting i think it was level 4 or 5. After i logged in they changed around the level of my cards. Alot of my commons was level 1. I now had a level 3 Ork Warlord which i before did not have. One of my epics which was level 1 was now level 3. And Rare cards which i had in level 5 was 3 or 2. 


Yeah pretty much. I just wish I had an update on when this might be fixed.
My game became unblocked for a day or so but now it’s back to updating game content yet again. Anyone got anything that has worked for them? Support is obviously a joke.
I’ve tried basically everything I could think of and no luck. It really seems like it’s something on their end. I noticed it happened to me both times, when I was in the process of opening several comets. I wonder if they blocked it intentionally to thwart would be cheaters.

Heya everyone! For those having the same issue, try messaging the Facebook page: https://www.facebook.com/aosrealmwar/ . I got a reply within an hour and it was fixed straight away - that was probably luck that they responded that fast, but give it a try!

Login or Signup to post a comment